Forum

Flogan's Scout crosshairs.

Created 1st February 2011 @ 18:08

Add A Reply Pages: « Previous 1 2 3 4 5 Next »

JackY

make for 1366×768 plz

Koeitje

AUTOBOTS

Quoted from freshmeatt

[…]

To make it bigger, you have to change the ‘tall’ property for your crosshair font in ClientScheme.res (requires restart of engine each time you change it), e.g.

m0refont8
{
"1"
{
"name" "Surface-Medium"
"tall" "8" <--
"additive" "0"
"antialias" "1"
"outline" "0"
}
}

to
m0refont8
{
"1"
{
"name" "Surface-Medium"
"tall" "20" <--
"additive" "0"
"antialias" "1"
"outline" "0"
}
}

What is the logic behind that size thing? Pixels? Percentage?

Engine restart = reload game or reload map?

Flogan

Quoted from Koeitje

[…]

What is the logic behind that size thing? Pixels? Percentage?

Engine restart = reload game or reload map?

Pixels.

Game restart.


Last edited by Flogan,

Flogan

Quoted from JackY

make for 1366×768 plz

do you mean 1360×768?


Last edited by Flogan,

JackY

nope.1366×768.Laptop

Wabbeh

Hey, I installed the cross liek you said to, but it doesnt work (((
-Gmang hud
-didnt replace anything, just added them to sections
-also, my friend said that I could get this to show up for only scout by doing something with it being visible in minmode?

Flogan

By the way, if the crosshair doesn’t line up with your spread, set your fov_desired to 90.

Added this to the original post too.

Flogan

Quoted from Wabbeh

Hey, I installed the cross liek you said to, but it doesnt work (((
-Gmang hud
-didnt replace anything, just added them to sections
-also, my friend said that I could get this to show up for only scout by doing something with it being visible in minmode?

I don’t know, but Gmang hud has a lot of outlined stuff, maybe some of the settings in it is interfering.

for the minmode thing, add a “visible_minmode” “0” under the “visible” “1” like this:


xHair
{
"controlName" "CTFLabel"
"fieldName" "xHair"
"visible" "1"
"visible_minmode" "0" <---
"enabled" "1"
"zpos" "1"

"xpos" "c-7"
"ypos" "c-7"
"wide" "13"
"tall" "13"

"font" "xHair"
"labelText" "+"
"textAlignment" "center"
}

Then in your scout.cfg file add cl_hud_minmode 0 and in all the other class .cfg files add cl_hud_minmode 1 or the other way around.

G-Mang hud has some minmode settings though. To fix this open hudlayout.res and do a search for _minmode (ctrl+b in notepad) and delete all of the lines that include it.

If this break something else within G-Mang hud I can maybe have a talk with G-Mang about adding it as an option for the hud.


Last edited by Flogan,

sKaz

KP

can i make it any wider?
and can you explain “step by step” how to make it change when im not playing as scout? :)

Koeitje

AUTOBOTS

If it doesn’t work, make sure you paste it BEFORE the last } in the files.

Flogan

Quoted from sKaz

can i make it any wider?
and can you explain “step by step” how to make it change when im not playing as scout? :)

Which part of the crosshair do you want widened?

I’m really bad at explaining stuff, but i’ll try.

When you open your hudlayout.res file with the changes you’ll see 9 defs called xHair and DotHair to DotHair8 (9 defs in total). They all look something like this:


DotHair2
{
"controlName" "CTFLabel"
"fieldName" "DotHair2"
"visible" "1"
"enabled" "1"
"zpos" "1"

"xpos" "c7"
"ypos" "c-13"
"wide" "6"
"tall" "6"

"font" "DotHair"
"labelText" "."
"textAlignment" "center"
}

The one called “xHair” is the cross (or dot) in the middle.
The ones called “DotHair” are the dots around.
They all have a line that says “visible” “1”, that means they’re visible.
If you want them to be visible only in minmode, you should change all of these to 0 and add a line beneath them that says “visible_minmode” “1”.

Like this:

"visible" "0"
"visible_minmode" "1"

Save the file and close it.

Now go to your tf/cfg folder and find your class configs “scout.cfg, soldier.cfg etc.”
In your scout.cfg file add “cl_hud_minmode 1” (without the quotes) and in all other class config files add “cl_hud_minmode 0”

That should do the trick.

Edit: you can leave the xHair visible if you want the middle part of the crosshair (dot or cross) to be visible when you’re playing other classes.


Last edited by Flogan,

JackY

Hey wat abot me?

Flogan

Quoted from JackY

Hey wat abot me?

Sorry, I’ll do other resolutions later. (probably starting with the more common ones though).

JackY

ok w8 it

konr

idd.

http://i.imgur.com/qv53h.png
There’s mine.

Add A Reply Pages: « Previous 1 2 3 4 5 Next »