Forum

Random fps drops

Created 29th September 2015 @ 13:55

Add A Reply Pages: 1

Loco

Mayo

Hi i just built a new rig running a 980TI On win 10 64bit   skylake cpu clocked at 4.5ghz 120hz monitor and have noticed weird frame drops from like 200 fps to 80fps in certain point of the maps.so i’ve done the usual disable steam cloud driver refresh,anyone else suffered similar issues?or has any tips/Hints regarding this issue:)

repu

i got a beastly setup too (at least for tf2), and i also get random hiccups while otherwise having around 200-300 fps.

NeuTronas

I had huge hiccups on Windows 10 until I turned off Windows Defender completely. Because you can’t properly turn off Real time scanning
To do that follow the steps:

Win + R buttons
Type “gpedit.msc”. Run it
Navigate to: Computer Configuration > Administrative templates > Windows components > Windows defender.
Then right click “Turn off Windows Defender” and Edit it.
Choose “Enabled”, Apply and then click OK :)

Hope it helps


Last edited by NeuTronas,

frixx

LG

“so i’ve done the usual disable steam cloud driver refresh”

Whats that, and how do you do that? I have been encountering same problems and want to find out how to fix.

Mundi

dogs

try running on dx8, skins will fuck ur fps up


Last edited by Mundi,

DX8 or running with textures on high/very high will stop the fps drops. It’s the shitty skin quality that makes the fps drop. Once they’re all pretty the drops go away.

repu

Quoted from Mundi

try running on dx8, skins will fuck ur fps up

Quoted from Tomu

DX8 or running with textures on high/very high will stop the fps drops. It’s the shitty skin quality that makes the fps drop. Once they’re all pretty the drops go away.

i’ve been running dx8 for ages, might just try disabling windows defender.

Add A Reply Pages: 1