Forum

60 FPS Cap

Created 25th October 2017 @ 22:20

Add A Reply Pages: 1

Marshy

Epipslon

No idea about computers. I was having issue with my HP Envy 17 Notebook just not charging even when plugged in and it still just says plugged in not charging often.

Laptop has been dropped multiple times and the side of it is open and gets really hot

around 70 degrees plus according to speccy.

Was getting around 100 fps sometimes 120 constant.

I did some things to help with power problem cus it would jst be plugged in and stop charging and i’d lose frames or it would shut off.

Now it will not go above 60fps no matter what on TF2. Reinstalled, removed configs and cfgs. Tried 2 different fps cofigs, (b4 i was using chris’s max frames and getting 121 fps)

Ran hl2 and my fps is fine around 120-80

But fps no matter what is stuck at 60 fps.

Sorry or bad explanation i have a theory its like going into power mode or some shiz and capping it. Also to try and fix issue i installed geforce experience upadted driver and used nvidia control panel. V sync off. and set to high performance on all settings i can find.

Any help!?!? :(

akachu

BOBBY B

fuck around with the power settings

and please get a sock around ur vacuum and clean that fan out.


Last edited by akachu,

narkkari

WNDR
kiti

try fiddling around with your gpu drivers, probably a framerate lock somewhere in there

Nightmare

SGrill
dab

70 degrees is perfectly healthy for a laptop cpu. Mine gets about 87 degrees during intensive workloads such as rendering. They’re designed to stand more heat.

Can’t really conclude much on “HP envy 17” It’d be great if you could specify the CPU and GPU. A few things that I can think of is if you’re running an AMD APU that AMD put your tf2 settings at a 60fps framelock. Nvidia settings might have the same.

You can try to put your laptop at “High performance” in the power options tab.

Try to reinstall your config and make sure that fps_max is set at 0 (which is unlimited) you can even try to reinstall tf2, maybe the pyro update caused some issues.

Clean your laptop using DDU (Display Driver Unistaller) and install fresh drivers.

Another option that I’ve seen before in laptops is that it suddenly decides to run tf2 on the intel graphics rather than the dedicated video card, which also means it has less GPU performance (not that tf2 is very gpu intensive) but it can make a difference.

Marshy

Epipslon

Ok so did a windows hard reset. Got stuck on 99% for 16 hours. Then power went off.

Started up, re installed steam and tf2. Still capped 60 fps. Hard stuck doesnt ever go higher. Or lower.. (Literally did nothing else xcept install discord)

I have Nvidia Geforce GTX 850M

Intel Core i75500U CPU @ 2.40GHz (4CPU)

Any further ideas. Other games are fine.

Bte about power fixes. I tried stuff like updating bios and unplugging battery and turning on laptop with just ac plugged in. I still have issue where sometimes the laptop doesnt register ts being charged. But wen i tested laptop was 100%.

Ok so i am getting somewhere. I ran in windowed mode. Now the fps is not capped. However this hasn’t SOLVED it for me because before i was getting higher frames as i was running fine on fullscreen but now windowed mode atleast doesnt hard cap at 60. Any further advice?


Last edited by Marshy,

Nightmare

SGrill
dab

Edit: There’s a thing called “vsync” vsync will cap your fps at your monitor’s refreshrate which is 60 hz (probably) so either you turned this on in tf2 or this is turned on in your nvidia settings. Vsync doesn’t work in windowed mode, only in fullscreen mode so that might be the problem.

First see if tf2 got it turned on, go to options -> video -> advanced and see if “wait for virtual sync” is turned on. If not, try turning it on with fullscreen and then turning it off. If it’s still capped at 60fps you might have to check your nvidia drivers.

In the nvidia drivers, go to Manage 3D settings -> global settings -> Vertical sync and turn that off.


Last edited by Nightmare,

Marshy

Epipslon

thanks nightmare didnt know windowed mode disables it. Already checked nvidia control panel, vy snyc defntiely off same with tf2. Any further advice guys? Side note i havent recorded temperature wen the side of laptop (where the case is broken and its exposed) is really hot, i jst turned on tf2 alt tabbed back and saw the temp it didnt get to a really stressfull part nor did i wait for it 2 heat up so that 70 degrees probably not accurate.

kKaltUu

R6S
SDCK

nvm

Also when you said “before” do you mean before and after the jungle update?


Last edited by kKaltUu,

Nightmare

SGrill
dab

I guess the last piece of advice I can give is to use DDU to clean your drivers and then perform a fresh install. Apart from that, temperatures can’t really give a cap, if your cpu would get too hot it would throttle the cpu but wouldn’t put a 60fps cap at the start.

You might also want to give “MSI afterburner” a try, with that program you can monitor the cpu, gpu and ram usage. It also gives the temperatures

Marshy

Epipslon

thanks for continued advice appreciate u guys trying 2 help. By before I do indeed mean before the pyro update. I installed ddu and uninstalled in safe mode. Should I now re install drivers from nvidia website or can u do it with the program. I will also install afterburner although not sure wat u want me to do with it. Tested once i removed, not installed new drivers yet, no notfication of windows auto installling any either. 60 fps hard cap still. Also if fps_max is not set to 0 and me intially booting tf2 in windowed borderless and then switching to full screen would that possibly be a reason for it 2 be capping or prevent me from testing?

Jan

(League Admin)
|FV|

Quoted from Marshy

Should I now re install drivers from nvidia website or can u do it with the program.

DDU does not offer installing drivers so just download them from Nvidia’s site.

Adje

GIEL
dab

Here are a couple of things you can try.

I’m assuming you are on Windows 10 when you were referring to Windows. Windows 10 comes pre-installed with the Xbox app, which forces V-sync in fullscreen applications. Either disable Game DVR and the Game Bar or even better, simply remove the Xbox app. You can do this in Powershell with the following command:

Get-AppxPackage *xbox* | Remove-AppxPackage

If that didn’t do the trick, try this registry tweak.

https://www.tenforums.com/tutorials/51180-enable-disable-game-dvr-game-bar-windows-10-a.html

Make sure your fps is not capped at 60 in-game. Either set fps_max at 0 to leave it uncapped or cap it at 300 as 0 can cause some memory leaks (personally haven’t had this problem but I’ve read this several times in documentation from several fps configs). Check your launch options for +fps_max, very unlikely you’ll have this launch option as nobody uses it but worth checking anyway.

Also make sure that V-sync is not enabled in your NVIDIA Control Panel (check for both general and TF2-specific settings). Alternatively download nvidiaInspector and check if V-sync is disabled.

https://puu.sh/yaBPF.png

If none of that worked and you are 100% positive it does not happen when you’re playing in windowed mode, go to hl2.exe → Properties and then choose to disable fullscreen optimizations.

Nightmare

SGrill
dab

Quoted from Marshy

thanks for continued advice appreciate u guys trying 2 help. By before I do indeed mean before the pyro update. I installed ddu and uninstalled in safe mode. Should I now re install drivers from nvidia website or can u do it with the program. I will also install afterburner although not sure wat u want me to do with it. Tested once i removed, not installed new drivers yet, no notfication of windows auto installling any either. 60 fps hard cap still. Also if fps_max is not set to 0 and me intially booting tf2 in windowed borderless and then switching to full screen would that possibly be a reason for it 2 be capping or prevent me from testing?

You ran tf2 without nvidia drivers installed and you still had the 60 fps cap? That would mean that tf2 is using your intel graphics rather than your nvidia graphics. You should install new nvidia drivers and specify to use your “Nvidia processor” in the “Manage 3D options” tab of your nvidia settings. That should fix it

Marshy

Epipslon

Ok so i did the following.

Uninstalled drivers again using ddu in safe mode. (Recommended setting so it restarts). Instantly set to flight mode.

Ran the driver installation i downloaded from the nvidia website. Definitely correct one.

I got this message.

‘the nvidia driver is not compatible with this version of windows. This graphics driver could not find ccompatible graphics hardware’

Gcard is showing in device manager, no hidden devices with errors in device manager.

Any ideas? ‘cus atm i cant install the drivers rip. Also tried the version of driver before the latest. Same problem.

Nightmare

SGrill
dab

Try to download the drivers again and specify the correct card. If that doesn’t work then you can try to manually install drivers since the card showed up in the device manager

https://www.custompcguide.net/2-methods-to-fix-nvidia-installer-failed-issue-for-geforce-video-cards/

Give method 1 a try

Add A Reply Pages: 1