Forum

Logitech G19 Key Binds

Created 6th December 2011 @ 14:40

Add A Reply Pages: 1

Mukuluku

968 days ago

Hello!
I need some help with my new Keyboard!
I have at the Keboard 12 extra Keys and i want to bind it with an voice command, chat massage or an rcon command!
But it doesnt work when i write: bind “g1″ “say_team **Charge Ready**”

So what i have to do that it works?

rytis

IsF:LT

968 days ago

bind g1 “say_team **Charge Ready**”
dunno if its the problem , but I fixed it :D

Mukuluku

968 days ago

Quoted from rytis

bind g1 “say_team **Charge Ready**”
dunno if its the problem , but I fixed it :D

nope that is not the reason!

Monkeh

.:ne:.
.:ne:.

968 days ago

// Fake uber and teamchat
alias “fakeuber” “voicemenu 1 7;say_team “It’s fake Nublet!”
bind “m” “fakeuber”

Also, try to edit a key in tf2 options with it and make sure tf2 recognises it as g1, see what it’s called when you assign it to something.

Si^

Pokeman
[PG]

968 days ago

75% sure tf2 won’t recognise G keys. Unless you create a macro on the fly.

Permzilla

(Head Admin)
#hobbit
007

968 days ago

Can’t get my S keys to work on my sidewinder x4, don’t know if they will for yours

Ghent

TSUN~

968 days ago

G keys aren’t recognized by tf2, if you want to use them just have it point to an obscure key on your keyboard and alias that key.

Spike Himself

(Honorary Admin)
SwC
TC.Storm

968 days ago

Go into options -> keyboard and do the binding there (just to see if it works). If that works, save, and find the bind in your config.cfg file. If that doesn’t work -> macros!

Oxy

TC.Strike
TC.Crash

968 days ago

Quoted from Permzilla

Can’t get my S keys to work on my sidewinder x4, don’t know if they will for yours

Yah I have exactly the same problem as with my x6. They can’t be directly assigned but I still manage to use a couple of them by assigning the S keys to unused buttons that are in awkward places like + and then binding buttons in game to + and therefore the S key. tl;dr its a pain in the butt.

edit: just noticed Gntmn already suggested this, i should l2r


Last edited by Oxy, 968 days ago

Mukuluku

967 days ago

Quoted from Spike Himself

Go into options -> keyboard and do the binding there (just to see if it works). If that works, save, and find the bind in your config.cfg file. If that doesn’t work -> macros!

so which macro i have to make or how that works on tf2?

Mukuluku

916 days ago

bump!

Miek

prfsnl gmr

915 days ago

You need to bind the G key to some unused standard key (using the Logitech software), then you can bind that standard key to something in TF2.

AnimaL

912 days ago

Quoted from Miek

You need to bind the G key to some unused standard key (using the Logitech software), then you can bind that standard key to something in TF2.

this
i have g keys bound to keypad, so g1 is KP_DOWNARROW and so on


Last edited by AnimaL, 912 days ago

Add A Reply Pages: 1