Forum

SrcDemo² - Render smoother demos, faster.

Created 10th March 2012 @ 20:08

Add A Reply Pages: « Previous 1 2 3 4 Next »

Wind

766 days ago

Quoted from Decoy

what are guys using to compile the pngs? VIrtual dub dosent seem to recognize all of them since the image numbers jump from ~600ish to ~3000ish just randomly. Is there a workaround?

That shouldn’t happen, unless you’re naming the files weirdly (like “startmovie srcdemo/part1″, because then SrcDemo2 will get file names like “part10001.tga” and get confused (where are the previous 10000 frames?)) or if you render multiple demos with the same name in the same session (because then it’ll look as if you just went back in time of the first demo).

As for the others having trouble getting it running, read the Facepunch thread/Steam threads for detailed instructions. The tl;dr is: Get a 32-bit JVM, preferably a server one, and the [Link]Dokan library[/url].

Or, if you’re on OS X, just download a preview version here, all you need is a FUSE-compatible library ([Link]Fuse4x[/url] (preferred), [Link]OSXFUSE[/url], or [Link]MacFUSE[/url]). The OSX version is only available as a command-line program (which the Windows version has too, btw), which you can run using:
/Applications/SrcDemo².app/Contents/MacOS/srcdemo2 --srcdemo-cmd

(Windows users can just run SrcDemo2-cli.exe)

Wacked

766 days ago

Quoted from murje

Here is a quick preview. 720 fps 180 shutter angle 30fps output [Link]

I dont edit any movies, but I’d really dislike the ghost / trace that is visable here and there throughout the video. Clearly seen on the heavy in the 2nd clip on gully.

Maffi

Saints
-chess-

766 days ago

Quoted from Wacked

[...]

I dont edit any movies, but I’d really dislike the ghost / trace that is visable here and there throughout the video. Clearly seen on the heavy in the 2nd clip on gully.

Think thats cuz of pldx tool but im not sure :xx

murje

cvx|

766 days ago

Quoted from Wacked

[...]

I dont edit any movies, but I’d really dislike the ghost / trace that is visable here and there throughout the video. Clearly seen on the heavy in the 2nd clip on gully.

It is caused by running the game with high graphics. Explosions have that kind of effect.

Decoy

PLM

766 days ago

Quoted from murje

[...]

tga is the way to go

oh, i thought it records only pngs, didint see the tga option, will try that later and see how it works

Skyride

DUCS

766 days ago

It’s great. I’ve been meaning to make a tutorial for quite a while on it. It’s a lot more complicated than the regular recording methods but shit loads better.

Just need to get around to fixing VHCapture.


Last edited by Skyride, 766 days ago

Skyride

DUCS

766 days ago

Quoted from Decoy

[...]
oh, i thought it records only pngs, didint see the tga option, will try that later and see how it works

The older version only did png’s but you can choose on the newer ones.

Decoy

PLM

766 days ago

basically its the same with .tgas and vdub just seems to take only the 1st 312 frames :/ and the file names jump from like ~1100 to ~9000 and i named them test1 and test3 so i don’t think thats the problem :/

the tga files start from test938.tga and end in test 10345.tga which is really wierd, srcdemo tool tells that ~900 frames were rendered out as the final product

also the tool wouldnt even start whitout the Dokan library and java so i have those covered

i used lawenas recording tool for the movie config, maybe that had to do with something getting screwed?


Last edited by Decoy, 766 days ago

Wind

766 days ago

Quoted from Decoy

basically its the same with .tgas and vdub just seems to take only the 1st 312 frames :/ and the file names jump from like ~1100 to ~9000 and i named them test1 and test3 so i don’t think thats the problem :/

Yes, that’s exactly the problem; re-read my post at the top of this page. If you name your recording “part1″, then the first frame that SrcDemo2 will receive will be “part10001.tga”, so it will think it just got the 10001th frame of a recording, which will make it confused.


Last edited by Wind, 766 days ago

Buffalo Bill

(Honorary Admin)
T⑨
T⑨

765 days ago

Quoted from Wind

[...]Yes, that’s exactly the problem; re-read my post at the top of this page. If you name your recording “part1″, then the first frame that SrcDemo2 will receive will be “part10001.tga”, so it will think it just got the 10001th frame of a recording, which will make it confused.

So how does this work with the PLDX Tool, which names the .tga sequences A1, B2 etc?

phife

бекон

765 days ago

Quoted from Buffalo Bill

[...]

So how does this work with the PLDX Tool, which names the .tga sequences A1, B2 etc?

lawena records it as a1_0001 etc, or am i remembering something not right?

also got the problem with it not starting when i clcik the .exe file, although i have the dokan lib and the latest java package installed. it only opens when i click the executable jar file

Wind

765 days ago

Quoted from Buffalo Bill

[...]

So how does this work with the PLDX Tool, which names the .tga sequences A1, B2 etc?

I am not sure, you’ll have to figure that one out. That seems like an odd naming pattern to me though…
SrcDemo2 should work wherever frames are recorded as
xx…xxc00…01.tga
xx…xxc00…02.tga
xx…xxc00…03.tga
xx…xxc00…04.tga
Where x is any character, and c is also any character but not a digit, and the string “xx…xxc” is the same across all filenames.

Quoted from phife

[...]

lawena records it as a1_0001 etc, or am i remembering something not right?

also got the problem with it not starting when i clcik the .exe file, although i have the dokan lib and the latest java package installed. it only opens when i click the executable jar file

Can you provide a log file (as generated by opening it in debug mode)?


Last edited by Wind, 765 days ago

Buffalo Bill

(Honorary Admin)
T⑨
T⑨

765 days ago

Quoted from Wind

[...]I am not sure, you’ll have to figure that one out. That seems like an odd naming pattern to me though…
SrcDemo2 should work wherever frames are recorded as
xx…xxc00…01.tga
xx…xxc00…02.tga
xx…xxc00…03.tga
xx…xxc00…04.tga
Where x is any character, and c is also any character but not a digit, and the string “xx…xxc” is the same across all filenames.

It’s not working at all actually, unless the fact I’m using the PLDX binds is what’s causing it to do nothing. I have to startmovie and endmovie myself, or should it work with the PLDX binds?


Last edited by Buffalo Bill, 765 days ago

Decoy

PLM

765 days ago

Quoted from Buffalo Bill

[...]

It’s not working at all actually, unless the fact I’m using the PLDX binds is what’s causing it to do nothing. I have to startmovie and endmovie myself, or should it work with the PLDX binds?

i think its the binds, since the tools guide is actually saying you to manually write startmove srcdemo/blablabla

Quoted from Wind

[...]Yes, that’s exactly the problem; re-read my post at the top of this page. If you name your recording “part1″, then the first frame that SrcDemo2 will receive will be “part10001.tga”, so it will think it just got the 10001th frame of a recording, which will make it confused.

also huge thanks to you, got it working this way, just need to name my files differently

Wind

764 days ago

Quoted from Buffalo Bill

[...]

It’s not working at all actually, unless the fact I’m using the PLDX binds is what’s causing it to do nothing. I have to startmovie and endmovie myself, or should it work with the PLDX binds?

Correct me if I’m wrong, but I think that indeed PLDX’s record binds do not make the game save the .tga’s in the correct folder.

Add A Reply Pages: « Previous 1 2 3 4 Next »