Forum

Visual glitch

Created 1st January 2018 @ 19:29

Add A Reply Pages: 1

DocFlame

HK
wantsPizza

Hi guys, I have a problem with my game. Tried to remove/change hud/cfg and even tried uninstalling and doing -autoconfing in launch options, different res, different dxlevel, uninstalloing gpu drivers, uninstalling tf2 and even resetting my entire pc but with no good. Does anyone have an idea of what this is?
Thanks
Video to view: whenever i try to record with my computer it solves itself but gives me major fps drops. Same for screenshots. Took a video with my phone: https://www.youtube.com/watch?v=p6oR0J77dVs&feature=youtu.be

Nightmare

LvG
KAAS

What gpu do you have? And what’s the age of the gpu?

Does this problem occur in other games?

Adje

Leila+8

What is your refresh rate? Are you running your game at the same framerate as your desktop pc (you don’t set a custom refresh rate in launch options)? Does this problem happen in other games? What are you average gpu/cpu temperatures while playing? Does it happen all the time or only after playing for a while? Do you have Vsync disabled?

DocFlame

HK
wantsPizza

I have an Intel 4600 gpu and a monitor of 60hz. When I have vsync it stops but its leaving me with 10-20 fps (usually 150). I think that this gpu must be around 4-5 years old but it occurs in tf2. Not really sure how to check my desktop’s fps but its not slow.

AcidPeter

lit

had that too and updating the driver solved it, was a couple years ago and on an AMD gpu though

Nightmare

LvG
KAAS

At what dxlevel did you play tf2 before the problem occurred? Dxlevel 81 or 90?

Adje

Leila+8

Try disabling Vsync and removing any fps cap you might have (default is 300 but on some systems it puts it way lower than the actual defined value for reasons I don’t understand).

mat_vsync 0
fps_max 0

Have you checked if it happens in (borderless) windowed mode? Just put -windowed -noborder in launch options and see if that changes anything.

Have you disabled Game DVR? Windows 10 forces Vsync in some games, the easiest way to get rid of it is to remove Xbox integration entirely.

https://www.reddit.com/r/pcmasterrace/comments/34qzni/how_to_remove_xbox_integration_in_latest_windows/


Last edited by Adje,

DocFlame

HK
wantsPizza

No way but the windowed mode worked!

Thanks a lot guys!

Quoted from Adje

Try disabling Vsync and removing any fps cap you might have (default is 300 but on some systems it puts it way lower than the actual defined value for reasons I don’t understand).

mat_vsync 0
fps_max 0

Have you checked if it happens in (borderless) windowed mode? Just put -windowed -noborder in launch options and see if that changes anything.

Have you disabled Game DVR? Windows 10 forces Vsync in some games, the easiest way to get rid of it is to remove Xbox integration entirely.

https://www.reddit.com/r/pcmasterrace/comments/34qzni/how_to_remove_xbox_integration_in_latest_windows/

Add A Reply Pages: 1