Forum

Low LOD / Picmip for TF2 (Nvidia + ATI/AMD)

Created 26th July 2011 @ 10:11

Add A Reply Pages: 1 2 ... 19 Next »

Forsak3n

GGWP.pro

1098 days ago

This tutorial is for getting “quake like” graphics – [Link]
It was originally posted by nub on a mission long time ago.
Scroll down for ATI/AMD.

-Nvidia cards-

The First Variant:

1. Download this: NvidiaInspector

[Link]
1. Open NvidiaInspector.exe
2. Click the Settings button (middle-right) next to Driver-Version
3. Select Team Fortress 2 in the top left corner
4. Set Texture Filtering – LOD-Bias to 10 or 15 (higher means worse textures)
5. hit “Apply” in the top right corner.

This is also better than the RivaTuner thing, because it only affects Team Fortress and you dont need to change the settings everytime you want to play another game without ridculously bad textures.

.xml File Replacement

the xml with options for higher LOD-Bias added: [Link]

The Second Variant:

1. Download RivaTuner

2. Install RivaTuner.
(Usual procedure, extracts to somewhere like your desktop. Then browse to the setup file and follow the wizard.)

3. Set up RivaTuner.
First time you run the program you will have to wait for it sort itself out.
Once this has completed you will get to the main RivaTuner screen.
[Link]

3.1. Click the power user tab.
[Link]

3.2. Expand the “RivaTuner NVIDIA Global” menu. Enter a value in “LODBiasRange” of 15.
[Link]

4. Go back to the main tab. Then click on the little arrow Under “Driver Settings” next to where it says “ForceWare detected.” Click on the directX Symbol to open a new window.
[Link]

5. In the new window, adjust the slider to where you want it. Put it on 0 to turn off any changes (Application will decide the LOD). 15 will be worst textures.
[Link]

*It may have problems with some of versions of nvidia drivers.
The excellent ones (for me) are 197.45.

*This tutorial was posted originally by nub on a mission on his scout blog – [Link]

Scroll down for a cfg which will allow it to work on tf2.

————————————————————————————————
————————————————————————————————

-ATI Cards-

1. Download Ati Tray Tools.
2. Install it.
3. Open direct3d > settings > additional > texture lod adjustment.
4. Set it to 10, it’s almost the same like 15 in nvidia.

--CFG--
Config: [Link] (Added: 16.09.2011)

Thanks to Slate, Wiggz & Chris.

Koeitje

AUTOBOTS

1098 days ago

Put a warning in there that this is banned at ESL.

octochris

(0v0)

1098 days ago

RT doesn’t work with newer driver versions (I think it breaks with 2xx). Use NVIDIA Inspector instead, it works with 2xx, and it’s better for stuff like this anyway.

[Link]

slate

Animate.
CGAY&BB

1098 days ago

It’s not banned on ESL anymore, I’ve recently asked Anakin.

Is Nvidia Inspector a GUI for the Nvidia Profile Tool or did they rename it?

MIndye

1098 days ago

No love for ATI?

Koeitje

AUTOBOTS

1098 days ago

Quoted from slate

It’s not banned on ESL anymore, I’ve recently asked Anakin.

Ok cool. Guess I convinced him then :+

Forsak3n

GGWP.pro

1098 days ago

Quoted from MIndye

No love for ATI?

yup

dob

CPLAY
CGAY&BB

1098 days ago

Quoted from Forsak3n

[...]
yup

:’(

octochris

(0v0)

1098 days ago

Quoted from slate

Is Nvidia Inspector a GUI for the Nvidia Profile Tool or did they rename it?

That and more.

slate

Animate.
CGAY&BB

1098 days ago

Quoted from octochris

[...]

That and more.

hmm just took a look at it, neat.

But I seem to be unable to get it to allow a LOD Bias >3

EDIT:
nevermind, to achieve a LOD Bias > 3, you need export the “profile” and change the Setting (in the exported Profile):

SettingID:7573135
SettingValue: YOURDESIREDVALUE * 8

LODBias: 10 you would enter 80
for 15 enter 120.

octochris

(0v0)

1098 days ago

Quoted from slate

[...]

hmm just took a look at it, neat.

But I seem to be unable to get it to allow a LOD Bias >3

You can add a custom bias in CustomSettingNames_[i18n].xml. Sure, it’s XML and it’s a piece of shit. But you can just add something like:

<CustomSettingValue>
<UserfriendlyName>10.000</UserfriendlyName>
<HexValue>0x00000050</HexValue>
</CustomSettingValue>

slate

Animate.
CGAY&BB

1098 days ago

cheers and yay for two working solutions :)

EDIT: hmm your solutions seems cooler.

the xml with options for higher LOD-Bias added: [Link]

Mike

Epsilon

1098 days ago

Chris, is there a better program other than ATI tray tools for adjusting LOD? ty

octochris

(0v0)

1098 days ago

Quoted from slate

SettingValue: YOURDESIREDVALUE * 8

LODBias: 10 you would enter 80
for 15 enter 120.

Remember that this is all in hex, not in dec. 10 dec to hex is 50. 10 hex is 80.

Quoted from Mike

Chris, is there a better program other than ATI tray tools for adjusting LOD? ty

no idea, never used ati and never plan to.

Rokstanski

1098 days ago

ati try doesnt work for me, im using this textures [Link] i have no idea about performans effect

Add A Reply Pages: 1 2 ... 19 Next »